This site requires JavaScript for navigation. Please enable JavaScript for the best learning experience.
 

BGP does not perform load balancing. BGP is specifically designed to select the single best route to a destination, therefore it is not able to perform load balancing itself. However, if you can configure BGP over a virtual connection, you can get a Cisco router to balance traffic using up to six static routes.

USING EQUAL COST PATHS

To do so, you set up more than one equal cost path. Using static routes, you can easilly accomplish this. Each static route is configured to reach a matching prefix, and because they are static routes, have equal administrative distance. Most often, static routes are used between two points. BGP is then configured to run over that set of connections using the 'ebgp-multihop' command.

USING LOOPBACK INTERFACES

By setting up connections between two loopback interfaces, the routers can take advantage of the fact that the loopback interface is never down, and will be 'up' so long as it is reachable via the configured static routes.

CONFIGURING BGP 'LOAD BALANCING'

ROUTER A

interface serial 0
 ip address 1.1.2.1 255.255.255.252
interface serial 1
 ip address 1.1.3.1 255.255.255.252
interface loopback 0
 ip address 1.1.1.1 255.255.255.255

router bgp 1111
 network 1.2.3.0
 neighbor 2.2.2.2 version 4
 neighbor 2.2.2.2 ebgp-multihop 2
 neighbor 2.2.2.2 update-source loopback 0

ip route 1.1.1.1 255.255.255.255 1.1.2.2
ip route 1.1.1.1 255.255.255.255 1.1.3.2


ROUTER B

interface serial 0
 ip address 1.1.2.2 255.255.255.252
interface serial 1
 ip address 1.1.3.2 255.255.255.252
interface loopback 0
 ip address 2.2.2.2 255.255.255.255

router bgp 2222
 network 5.4.3.0
 neighbor 1.1.1.1 version 4
 neighbor 1.1.1.1 ebgp-multihop 2
 neighbor 1.1.1.1 update-source loopback 0

ip route 1.1.1.1 255.255.255.255 1.1.2.1
ip route 1.1.1.1 255.255.255.255 1.1.3.1

Bookmark this page and SHARE:  

Search

Support InetDaemon.Com

Get Tutorials in your INBOX!

Free Training